Wednesday, May 29, 2024

Kennedy, Menendez introduce bipartisan legislation to reauthorize NFIP, bring down policy rates

by BIZ Magazine

WASHINGTON – Sen. John Kennedy (R-La.), a member of the Senate Banking Committee, today joined Sens. Bob Menendez (D-N.J.) and Bill Cassidy (R-La.) in introducing the National Flood Insurance Program Reauthorization (NFIP Re) Act of 2023. 

“By making flood insurance unaffordable, the Biden administration’s Risk Rating 2.0 is making it impossible for Louisianians to protect their biggest assets—their homes. We must make sure that the NFIP works for the people who depend on it, and this bill would do that,” said Kennedy.

Congress can no longer afford to punt long-term reauthorization and reform of the NFIP. It’s time to put policyholders first and address the longstanding systemic issues with the program that came under the national spotlight in the aftermath of Hurricane Sandy. With disastrous flooding events becoming all the more common, we must work to create a more sustainable, resilient, and affordable flood insurance program that invests in prevention and mitigation efforts, and all while ensure hard-working Americans can have peace of mind in the event of a disaster,” said Menendez.

“Reforming the NFIP means making it affordable again. We need to ensure families are not priced out of the program,” said Cassidy.

The legislation:

  • Reauthorizes the NFIP for five years.
  • Caps annual policy premiums hikes at nine percent.
  • Freezes interest payments on the NFIP debt to reduce borrowing.
  • Increases the maximum limit for increased cost of compliance coverage.
  • Funds mitigation efforts.

Sens. Cory Booker (D-N.J.), Chris Van Hollen (D-Md.), Roger Wicker (R-Miss.), Kirsten Gillibrand (D-N.Y.), Cindy Hyde-Smith (R-Miss.) and Marco Rubio (R-Fl.) also cosponsored the legislation.

Reps. Frank Pallone (D-N.J.) and Clay Higgins (R-La.) are leading the legislation in the House of Representatives.

Text of the NFIP Re Act is available here.

You may also like

-
00:00
00:00
Update Required Flash plugin
-
00:00
00:00